Elevator Update 2.6.1 Available

We’ve released a maintenance update for our Generation 2 elevators that fixes a couple minor issues. You can get your updated elevator by rezzing your original shipping crates or using the redelivery terminal at our shop (if purchased in-world).

Updated all shells to 2.6.1:

  • __floorsettings in cars were missing the value of ArrivalVolume causing the arrival sounds (voice by default) to be muted.
    • You can work around this without updating your shell by setting ArrivalVolume=1.0 in your __floorsettings notecards in the call buttons in the car.
  • All shells that aren’t cars were updated just to match the version of cars. There are no other changes.

Updated script package to 2.6.1:

  • Exterior doors can now have their “Out of Service” object removed so that the spinning cube is not rezzed when in maintenance mode.
  • Minor internal changes to allow __floorsettings notecard to be updated via the update disk.
    • Any notecards that contain “__floorsettings” in their name will be removed from the buttons.
  • Added more information to the invalid serial number error to give tips on how to resolve the issue.
  • Added a startup tip instructing users to click Install on the controller.

Updated update disk to 2.4.0:

  • Gave it the ability to give a notecard to the call buttons in the elevator car.
  • Added “TransferNotecard” option to the _config notecard to facilitate the above.
    • Elevator scripts must be v2.6.1 for this to work. Update to 2.6.1 with TransferNotecard set to 0 and then update again with TransferNotecard set to 1 to copy over notecards.

Known issues:

  • Sometimes doors appear to be stuck open or closed. This is a bug in the SL sim code that prevents the server from sending your client the update that tells it the doors moved.
  • You can likely work around this by changing your door mode or reduce the amount of steps in the animation to make them move further in each step.
  • See https://jira.secondlife.com/browse/SVC-1945 for the bug report.
  • I’ve tried to work around this bug for 2.6.1 to no avail.

Leave a Reply

Your email address will not be published. Required fields are marked *